25.06.2026
Laden von Word-Dateien direkt in SuperMailer als HTML
-
Microsoft hat im Zuge von Sicherheits- und Architektur-Updates für Microsoft Office 365 Parameter zum Speichern einer Word-Datei als gefilterte HTML-Datei geändert,
damit kann im SuperMailer über "Text..." - "laden" nicht mehr
eine Word-Datei gewählt, konvertiert und direkt in SuperMailer
geladen werden. Mit der nächsten SuperMailer-Version wird der
Fehler behoben sein. Bis dahin ist nur ein manueller Import
möglich:
- Word-Datei selbst im Word öffnen
- im Word die Datei als Webseite, gefiltert (wichtig
gefiltert!) speichern
- im SuperMailer über die Schaltfläche "Text..." die
HTML-Datei laden lassen
- Newsletter mit
Word erstellen
27.04.2026
"Fehler 255 - Outlook kennt mindestens einen Namen nicht"
-
Microsoft hat anscheinend bei einem Outlook-Update einen Fehler gemacht, so dass beim Versand über Outlook der Fehler
"255 - Outlook kennt mindestens einen Namen nicht" erscheint.
Im Forum
https://board.superscripte.de/viewtopic.php?p=53097 ist beschrieben, wie man die Outlook-Kontakte zur Suche nach Adressen wählen kann,
um den Fehler zu umgehen.
20.02.2026
Update OAuth2 Schlüssel für den Zugriff auf Microsoft 365 (Office 365)
-
Erhalten Sie den Fehler:
"Der Zugriff für den Versand wurde nicht gestattet!
OAuth2 failed to complete. exchangeCodeForToken..."
oder
"The provided client secret keys for app 'id' are expired.
Visit the Azure portal to create new keys for your
app: https://aka.ms/NewClientSecret, or
consider using
certificate credentials for
added security: https://aka.ms/certCreds."
Die Zugriffsschlüssel sind abgelaufen, dies ist alle 2 Jahre
der Fall.
Führen Sie das Online-Update aus, laden Sie die neuen Schlüssel, beenden Sie SuperMailer und starten Sie SuperMailer erneut.
Es muss eine erneute Browserauthentifizierung erfolgen.
-
Ab dieser Version können per HTTP über die Amazon SES HTTP API und über die Gmail API Serienemails, Newsletter
und Transaktions-E-Mails versendet werden. Die HTTP API sollte nur verwendet
werden, wenn ein SMTP-Zugriff im eigenen Netzwerk per Firewall nicht gestattet ist. Der Versand per HTTP ist immer langsamer und limitierter als der direkte Versand per SMTP,
besonders bei der Gmail API ist dies spürbar.
Für die Gmail API muss selbst eine OAuth2 App in der Google Cloud erstellt werden.
-
Beim Versand per HTTP über die Microsoft Cloud (Microsoft Graph
API) werden jetzt unterschiedliche Absender-E-Mail-Adressen mit
Speicherung des abgerufenen Tokens unterstützt. Diese
Variante unterstützt jetzt ebenfalls korrekt einen HTTP
Proxy-Server.
-
Für Transaktionsmails (z.B. E-Mails mit Rechnungen/Auftragsbestätigungen,
keine Newsletter oder Serienmails) muss kein Abmeldelink in der
E-Mail verwendet werden, es sollte aber ein List-Help-Header im
Header der E-Mail hinterlegt werden. Unter Menü Projekt -
Abmeldelink kann der Versand als Transaktionsmails, anstatt als
Newsletter/Serienmails aktiviert werden, zusätzlich kann der
List-Help-Header mit einer URL zur Erklärung, warum der
Empfänger die E-Mails erhält, z.B. Auftragsbestätigung oder
Rechnung, gesetzt werden. Soll der Versand von
Transaktionsmails über den kostenpflichtigen SMTP-Server der
is-Fun Internet Services
GmbH erfolgen, ist die Angabe des List-Help-Headers
eine Pflichtangabe.
-
SuperMailer unterstützt jetzt
Spintax, dies kann zur einer Verbesserung der Zustellbarkeit
der E-Mails beitragen. Es können damit mit einer Textvorlage
mehrere Varianten eines Newsletters oder allgemein E-Mail
erstellt und versendet werden, z.B. Mit der Newsletter Software SuperMailer lassen sich
{Serienmails|HTML-Newsletter|Transaktionsemails} {mit individuellen Anhang|ohne Anhang} erstellen und versenden.
-
Die Verwendung des HTML-Tags <pre> wird jetzt korrekt umgesetzt,
die Formatierung des enthaltenen Texts wird nicht mehr verändert.
-
Für den Import der Kontakte aus der Microsoft Cloud werden
Kategorien jetzt unterstützt. Microsoft bietet keine API zur
Bestimmung der Kategorien, SuperMailer ruft daher maximal 1000
Kontakte ab, bestimmt die Kategorien und stellt diese als
Auswahl zur Verfügung.
-
Neue
interne Funktionen sf_incminutes(),sf_inchours(),sf_guid()
und sf_uid(), zur Berechnung der Uhrzeit und Erstellung einer
eindeutigen ID/GUID.
-
Behebt folgende Fehler
-
Beim Tracking oder Umfragen kann das
Passwort jetzt für die MySQL-Datenbank Anführungszeichen (") und
Hochkomma (') enthalten.
-
In Tabellen wird jetzt als Standard valign="top" für
die Ausrichtung oben gesetzt, nicht wie bisher die vertikale mittige Ausrichtung.
-
Das Speichern eines Bild als neue Datei im Bildgröße-Ändern-Dialog funktioniert wieder.
-
Bei Verwendung von mehreren
SMTP-Servern mit Limits kann der angezeigte Name
überschrieben werden.
-
Der Platzhalter [EMail_DomainPartNoTLD]
gibt den Domain-Namen und Top-Level-Domain zurück.
-
Behebt den Fehler beim Spamtest
"LIST_PARTIAL Has incomplete List-* header set",
es wird ein zusätzlicher Header List-Id gesetzt.
-
Beim Import von mehreren SMTP-Servern mit Versandlimits
ist ein Beispiel für den Aufbau einer solchen Datei
enthalten.
-
Build 2566
-
sha256 anstatt sha1 wird jetzt für
S/MIME signierte E-Mails verwendet
-
Beim Versand per BCc gab es
fälschlicherweise eine Fehlermeldung, dass nicht mehr als 50
Empfänger beim Versand per Amazon SES erlaubt wären, obwohl
Amazon SES nicht gewählt wurde.
-
Beim Versand von Transaktions-E-Mails
über den kostenpflichtigen SMTP-Server der
is-Fun Internet Services
GmbH gab es fälschlicherweise eine Fehlermeldung, dass
der HTML-Code des Abmeldelinks hinterlegt werden muss.
-
Beim Testen des Abmeldelinks wird nur
noch HTTP HEAD, anstatt wie bisher HTTP GET ausgeführt.
-
Build 2567
-
Werden mehr Empfänger aus einer
Text/CSV-Datei importiert und das durch die Lizenz gesetzte
Limit wurde überschritten, dann kann es zu einer
Zugriffsverletzung und es wurde nichts importiert.
-
Beschleunigt die Bearbeitung von
großem HTML-Code, mit vielen, per data/image base64,
eingebetteten Bildern. Bilder sollten nicht direkt per data/image
eingebettet werden, das kann zur Nicht-Anzeige der E-Mail
führen, falls zu viele Bilder enthalten sind.
19.03.2025 Umstellung Microsoft Outlook 365 auf Outlook (New)
-
Microsoft wird ab Januar 2025 beginnen das klassische Microsoft Outlook
Desktop-Programm auf die neue Outlook App (New) umzustellen. Dies sollte verhindert werden, ansonsten können
Sie mit SuperMailer nicht mehr die Versandvariante "über Microsoft Outlook" verwenden, denn das neue Outlook (New) lässt sich nicht mehr per COM-Schnittstelle
automatisiert fernsteuern. Es ist damit ein automatisierter Versand von Serienmails und Newslettern über Microsoft Outlook nicht mehr möglich.
Sollten Sie Outlook-Addins verwenden, z.B.
MONewsletter oder
OutlookAddressExtractor (Freeware), dann sind alle diese Add-Ins mit
der neuen Outlook App (New) nicht mehr nutzbar.
Sollten Sie die Serienmails und Newsletter per SMTP-Server, über Webspace oder direkt über die Microsoft Cloud
(GraphAPI) versenden lassen, dann spielt die Umstellung des
alten Outlook auf die neue App keine Rolle.
Umstellung von
Outlook-Versand auf SMTP-Server für Microsoft 365
Informationen zur Verhinderung des Updates mit Verweis auf DATEV finden Sie hier:
https://www.borncity.com/blog/2024/12/17/datev-empfiehlt-die-neue-outlook-app-zu-blockieren/
-
Zur Unterscheidung der Versionen, so sehen
Outlook Desktop und
Outlook New aus.
-
Gespeicherte Kontakte können aus Outlook New über Importieren
-
aus Microsoft Cloud importiert werden. Die Kontakte
sollten alle in der Microsoft Cloud gespeichert sein.
-
Google hat den Dienst zur Erzeugung von QR-Codes per HTTP-Aufruf eingestellt, daher sind jetzt 2 andere Anbieter integriert. Die Möglichkeit zur Erzeugung von
QR-Codes durch SuperMailer selbst, besteht natürlich weiterhin.
-
Auch in SuperMailer zieht die künstliche Intelligenz jetzt ein. Mit OpenAI können Texte oder Bilder erstellt und im Newsletter verwendet werden. Zur Nutzung dieser
Funktion ist ein API-Key notwendig und es können bei intensiver Nutzung Kosten anfallen. In der
Hilfe ist erklärt, wie Sie eine API-Key bei OpenAI abrufen können.
-
Die Prüfung auf den DMARC-Record der Domain wird nicht mehr über die Abfrage der TXT records durchgeführt, da oft der DMARC-Record nicht enthalten. Es wird jetzt direkt
nach dmarc.<domainname> beim DNS-Server angefragt.
-
Beim Versand über Outlook wird jetzt, bei Aktivierung des Versands mit der im SuperMailer angegebenen Absender-E-Mail-Adresse, Outlook kontaktiert und geprüft, ob
es ein Outlook-Konto mit dieser E-Mail-Adresse wirklich gibt. Es kann so der Versand über ein falsches Konto unterbunden werden.
-
Bei Verwendung von mehreren SMTP-Servern mit Limits für den Newsletter-Versand kann jetzt eine CSV-Datei importiert werden. Die CSV-Datei muss mit Trennzeichen
getrennt alle Infos zu Servernamen, Nutzername, Passwort und etwaigen Limits enthalten.
-
Der Versand von E-Mails über SMTP-Server, z.B.
LANMailServer, die keinen Benutzername/Passwort erfordern, wird wieder korrekt ausgeführt.
Wird Benutzername/Passwort für die SMTP-Authentifizierung angegeben aber der Server erfordert keine Authentifizierung, wird dies ignoriert und der Versand durchgeführt.
-
In der Auswahlliste mit den Blockformaten Absatz, Formatiert, Überschrift 1-6..., können jetzt eigene Blockformate per Stylesheet definiert werden. Kenntnisse mit CSS sind Voraussetzung.
-
Behebt in der 64bit Version einen Fehler bei der Speicherzuordnung beim Import aus externen Datenbanken/dynamischen Textbausteinen.
-
Ein Download der Pixabay-Bilder ist wieder möglich.
-
Anpassung für ionos Webspace, damit die
gehostete E-Mail-Adresse als Absender verwendet wird.
-
Das Update auf die neueste Version der Newsletter
Software ist durch das integrierte Online-Update (Menü ? - Online-Update),
Austausch der Exe-Datei 32bit bzw.
Exe-Datei 64bit oder Installation der
kompletten Version
möglich.
-
Die Schlüssel für den Zugriff auf Microsoft 365 / Office 365 Konten mit OAuth2 sind aktualisiert, da diese abgelaufen waren. SuperMailer gibt bei Fehlern
beim Zugriff mit OAuth2 jetzt mehr Informationen aus, so dass die Fehlersuche erleichtert wird.
-
SuperMailer prüft jetzt vor dem Versand auf einen DMARC-Record für die Versanddomain, dieser kann die Zustellung der E-Mail verbessern.
Mit einem Doppelklick auf den möglichen Fehlereintrag in der Liste "Zusammenfassung/Fehlerprüfung" kann die Prüfung auf SPF-Record und DMARC-Record
dauerhaft deaktiviert werden.
-
QR-Codes können jetzt durch SuperMailer selbst erstellt und als Bild, eingebettet in die HTML-E-Mail, versendet werden. Der Aufruf über Google zur Live-Erstellung des
QR-Codes bei Anzeige der E-Mail steht weiterhin zur Verfügung.
-
Verbesserungen am Zugriff auf MySQL-Datenbank zur Speicherung der Newsletter-Empfänger, manchmal wurden zu viele oder zu wenige Zeichen über die MySQL-API gelesen.
-
Für die SMTP-Authentifizierung oder beim Abruf der Newsletter-Anmeldungen / Newsletter-Abmeldungen oder Abruf der unzustellbaren E-Mails dürfen die Passworte jetzt
Sonderzeichen enthalten, falls der E-Mail-Server diese unterstützt.
-
In personalisierten Anhängen, selbst konstruierte HTML-Dateien, kann per Google API ein QR-Code oder Bild eingefügt werden.
-
Neue interne Funktion sf_rand_image() ermöglicht es zufällig ein Bild aus den angegebenen Dateinamen in der E-Mail anzeigen zu lassen.
-
Wurde die Verwendung von DomainKey in der Versandeinstellungen aktiviert, dann wird automatisch ein CFBL-Address-Header in den Header E-Mail hinzugefügt, dies kann
zur Verringerung der Erkennung als Spam führen => https://docs.abusix.com/.
-
Behebt folgende Fehler:
-
Wurde in der Serienmailvorschau der Internet Explorer-Modus gewählt, wurde beim
Blättern auf den nächsten Newsletter-Empfänger Edge statt IE verwendet.
-
In reinen HTML-E-Mails mit eingebetteten Bildern über data/image werden die Daten jetzt umgebrochen, ansonsten könnte der E-Mail-Server
die E-Mail mit "line too long" ablehnen.
-
Update aller PHP-Scripte, damit PHP 8.3 unterstützt wird.
Bei Nutzung von MSSQL-Server für das Tracking kann die verschlüsselte Verbindung jetzt aktiviert werden.
-
Emojis im Eingabefeld für den Betreff werden wieder farbig dargestellt, nach einem Update von Microsoft Edge war dies nicht mehr möglich.
-
Der Cloud-Upload von SuperMailer-Projekten in Verbindung mit Microsoft Edge funktioniert wieder.
-
Die Funktion zur Zuordnung gleichnamiger Felder im Import-Dialog ist verbessert, so dass auch Felder mit Leerzeichen, Bindestrich und Umlauten automatisch zugeordnet werden.
-
In der Konfiguration des Browserlinks und Newsletter-Archivs können jetzt eigene Sprachen und Sprachenkürzel zur Übersetzung der Seite durch GoogleTranslator hinzugefügt werden.
-
In den Einstellungen kann jetzt im Feld "Ausgeben als E-Mail-Programm" ein eigenes E-Mail-Programm manuell eingegeben werden, diese Angabe sollte jedoch unterbleiben, weil dies
zur Spam-Erkennung führen kann.
-
Build 2501:
-
Ein fehlender Wert für refresh_token
wird bei OAuth2 ignoriert, löst keinen Fehler mehr aus.
-
Das Ändern von mehrzeiligen Texten im
Assistenten funktioniert wieder.
-
Beim Öffnen von alten
Empfängerdatenbanken wird das fehlende Feld "iLastNewsletterSendDateTime"
wieder korrekt hinzugefügt.
-
Build 2502: Behebt den Fehler beim
Spam-Test "MIXED_HREF_CASE Has href in mixed case", der HTML-Tag
A und andere HTML-Tags werden jetzt klein im Quelltext der
E-Mail geschrieben.
-
Build 2503: Behebt einen Fehler in der
64bit Version beim Import aus Textdateien. Weitere HTML-Tags
werden in Kleinbuchstaben in den HTML-Code übernommen, um die
Erkennung als Spam zu verringern.
error_get_last() korrigiert, so dass keine Fehlermeldung
array => string mehr erscheint.
Bei Nutzung auf ionos (1&1) Webspace muss bei der Erstellung des Scripts eine E-Mail-Adresse angegeben werden, die bei ionos gehostet ist,
externe E-Mail-Adressen sind nicht mehr bei ionos erlaubt (SendAsDenied).
-
Der Newsletter-Versand an eine große Anzahl Empfänger kann sehr lange dauern, daher können Versandtage und eine Versandzeit definiert werden. Außerhalb der Zeit
wird SuperMailer den E-Mail-Versand pausieren.
-
Beim Abruf der Trackingstatistik im Browser über das PHP-Script webstat.php werden jetzt grafische Charts dargestellt.
-
Ein Abruf der Ergebnisse der Umfragen ist jetzt ebenfalls über den Browser möglich. Benutzername/Passwort werden automatisch erstellt, diese Angaben finden Sie
unter Menü Projekt - Umfragen einrichten, Reiter Upload.
-
Personalisierte Anhänge als selbstkonstruierte textbasierte Datei können jetzt als
(digital signierte) PDF-Datei umgewandelt werden, WebView2 notwendig. Es ist damit
möglich Rechnungen oder Gutschriften mit einer HTML-Datei als Vorlage ohne Microsoft Office/OpenOffice/LibreOffice zu versenden.
Beispiel Rechnung als HTML-Datei unter Verwendung der internen
Funktionen und Umwandlung in PDF-Datei.
-
Es werden jetzt die neuen Platzhalter [~ID~], für die ID des Empfängers in der SuperMailer-Datenbank, und [~SUBJECT~] zur Anzeige des personalisierten
oder Variante des E-Mail-Betreffs im E-Mail-Text unterstützt.
-
In OpenOffice/LibreOffice werden Platzhalter in Hyperlinks korrekt ersetzt, wenn diese mit einem eingefügten Bild verknüpft sind.
-
Wurden mehrere SMTP-Servers mit Limits für den Versand definiert, dann können diese jetzt als Datei gespeichert und in einem anderen SuperMailer-Projekt wieder geladen werden.
-
Behebt folgende Fehler
-
Bei Auswahl einer Emojis-Kategorie wird wieder an die korrekte Position in Microsoft Edge/WebView2 gesprungen.
-
Bei Verwendung der Versandvariante über Webspace/eigenen Server mit bzip2-Komprimierung wird PHP 8 unterstützt und bzip2 kann jetzt
ebenfalls in der 64bit Variante verwendet werden.
-
Beim Import aus Excel-Tabellen wird HTML-Code in der Excel-Tabelle wieder korrekt unterstützt und Anführungszeichen nicht mehr entfernt.
-
Beim Import aus Excel gibt es die neue Option "Arbeitsblatt enthält berechnete Inhalte", diese muss aktiviert werden, um berechnete Zellen
korrekt durch SuperMailer importieren zu lassen.
-
Bei Anzeige der Umfrage-Ergebnisse für Umfragen mit Bild, wurde HTML-Code, anstatt des Bildes, angezeigt.
-
Die Umfrage-Ergebnisse konnten in PHP 8.1 nicht abgerufen werden, wenn es 0 Abstimmungen gab, da PHP 8.1 einen Fehler zurücklieferte.
-
Der Fehler beim Anzeigen und Speichern von Newsletter-Empfängern mit MySQL 8.x und sql_mode ONLY_FULL_GROUP_BY ist behoben.
Newsletter Software/Serienmail Software SuperMailer
Bewertung 4.7 von 5.0
basierend auf 6155 Bewertungen
|